TROUBLESHOOT US?

The site has been loading annoyingly slow for weeks now but I can’t seem to find the cause. I reduced the number of posts per page from 8 down to 4 and stripped off as many extraneous plugins as I could spare but it doesn’t seem to help. I’ve now taken off the exfm music player to see if that will help though I always thought that was a boon to readers.

Anyone with better web skills than me able to do some kind of diagnostic and figure out what the heck is going on? Much appreciated!

–O.W.

Comments

comment(s)

4 comments to TROUBLESHOOT US?

  • Gregg Dessen

    If you install the Firebug plugin for Firefox and run it against your site, you’ll see that the majority of the requests are to external sites: Facebook, Mixcloud, and Google.

    That said, when I ran it against your site, the homepage loaded fully in 6.22 seconds (not bad)… with much of the times being taken up by Facebook’s like buttons. There are also 6 unresolved requests to “http://static.ak.fbcdn.net/rsrc.php/v2/yG/r/gKj-I-L2iQ6.js” (also Facebook). I’m not sure what that script is for, but since it’s requested 6 times and never resolves, perhaps you could live without it.

    If you’d like me to share a screenshot with you that shows ALL of the requests generated by your homepage, please email me and I’ll send you the screenshot as an image.

    Otherwise, I can’t say that I think your site is loading slowly. Have others reported this, too? If not, perhaps it’s a connectivity issue on your side.

    Anyhoo… let me know if I can help further. I dig your blog and have been following for a while. Big ups!

  • Hey Greg: first of all, thanks much for the debugging help. I’m usually able to brute force my way around most technical problems but scripting is way out of my way wheelhouse even though I understand what may be happening in concept.

    The thing is: I’ve dumped all the FB related plugins save one and I can’t figure out why there’s six unresolved requests out there. I’m about to “reboot” the theme and see if that helps clean it up.

  • I’ve found the site really slow to load – to the point of not loading at all – for weeks, using Chrome. Today I thought of trying an Incognito Window in Chrome and it loads perfectly fine in that! Still not loading at all in a standard Chrome window. It loads fine for me in Safari (which I rarely use). Maybe there’s some extension or setting I have that’s making it slow… have you tried something similar?

  • I had a brainwave… I went to Facebook and logged out, then tried Soul Sides again and it loaded nice and quick! And if I go back to Facebook and log in, then Soul Sides still works OK. Very strange. I don’t know if this is the same issue you were having, but it’s odd that the site wouldn’t load at all for me until I logged out of FB.

Leave a Reply

  

  

  

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>